GHES (Github.beeone.at) bad performance - PR merges stuck

Incident Report for George Labs Status

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 06:36 CEST

Identified

The issue has been identified and to avoid interferience with regular operations, a fix will be applied on Friday July 3rd at 6.30 am.
Posted Jul 02, 2026 - 16:57 CEST

Investigating

GHES facing errors with some high load event, currently impacts PR merges and GHA.
Posted Jul 02, 2026 - 14:06 CEST
This incident affects: Development Services (Github Enterprise Server).